eslint-plugin-react-hooks feature request: enforce naming convention for useState()
Do you want to request a feature or report a bug?
What is the current behavior?
There is currently no rule to enforce the standard naming convention for
What is the expected behavior?
It would be great to have a rule to enforce the standard naming convention for
const [x, setX] = useState(...)
For example, the rule would consider this an error:
const [x, setFoo] = useState(...)
This would ensure that all useState variables followed the same convention, i.e.
Which versions of React, and which browser / OS are affected by this issue? Did this work in previous versions of React?
All versions with hooks
I originally submitted a feature request for eslint-plugin-react: yannickcr/eslint-plugin-react#2417. It was suggested that I make the feature request here instead. I'm not sure which plugin would be the more appropriate place for this.
Problem with updating component state in the "Components" tab of React Developer Tools - Chrome extension
- 1. [Feature Request] Allow useEffect/useLayoutEffect to have previous values
- 2. Bug: React function component unmounts on state change.
- 3. Bug: SuspenseList revealOrder="backwards" is not consistent without tail props
- 4. Bug: Server hydration mistmatch and radio group with defaultChecked
- 5. Bug: disableRemotePlayback not recognized